WordPress 5.0 更新升级注意事项,怕出问题请先看本文

    2018年12月6日,最受期待的WordPress 5.0 版本正式上线。

    不同于以往的更新升级,这一次版本更新可谓是非常热闹,各大主流wordpress插件商都相继发表了申明,告诫大家不要急着升级,因为他们还没有准备好。

    yoast建议不要升级wordpress 5.0

    wpml建议不要升级wordpress 5.0advanced custiom fields建议不要升级wordpress 5.0

    看到这些推文,好像挺严重的样子,想必大家和我一样脑海里是下面这个画面。

    wordpress官方发布新版本提示更新,插件商却叫大家不要急着更新,到底是为什么?

    主要原因还是是因为wordpress 5.0的改动很大,连10年不变的默认编辑器都直接换新的了,插件商怕在兼容性上与wp主程序发生冲突,导致各种bug,给大家造成损失。

    wordpress新版默认编辑器

    wordpress老版默认编辑器

    既然没有人敢百分之百保证本次更新不出问题,所以一灯的建议是不要急着更新,等1到2个星期,以wordpress的尿性,一定会马上又发布新的版本。

    如果手痒请一定先做好网站备份,以防万一。

    说到这,大家一定很好奇wordpress 5.0都更新了些什么?一灯这就给大家介绍。

    WordPress 5.0更新有哪些新变化?

    相对于以前的更新,5.0不是打个补丁,补个漏洞那种小更新,而是直接多出来以下两个内容。

    1. Gutenberg WordPress 页面编辑器
    2. Twenty Nineteen WordPress 主题

    先说Gutenberg WordPress 页面编辑器,中文名古腾堡,如果你更新到5.0,以前的老版默认编辑器就不能使用了,而变成下面这个样子,对wordpress老用户来说,会变的非常不习惯。

    Gutenberg WordPress 页面编辑器

    但对于才使用wordpress的新用户而言,编辑页面的难度将大大降低,在没有像avada这种高级主题的辅助下,wordpress自身就可以实现模块化编辑,想要什么就添加相应的模块。

    wordpress模块

    其实,早从去年开始,wordpress就一直在布局自己的新版页面编辑器Gutenberg(古腾堡)。

    主要原因还是因为很多人都觉得wordpress太难了,编辑器不如一些半开源的CMS程序好用,不可以模块化编辑。于是4.8版本的时候,wordpress推出了Gutenberg(古腾堡)页面编辑器插件,先试一下水。

    结果呢有些意外,50万+的安装量,平均评分只有两分,没有一个5星好评。

    Gutenberg插件

    差评的原因主要来自老用户,因为Gutenberg真的很鸡肋,老用户平时都使用第三方开发的页面编辑器,比如avada的fusion builder,所以几乎用不到wp自带的页面编辑器。

    但如果要改个代码,进text模式什么的,就会用到默认编辑器,由于Gutenberg的原因,以前干净简单好用的默认编辑器变样了,使用习惯也不一样,不给差评就见鬼了。

    但wordpress官方最后还是一意孤行的把这个插件直接整合到了5.0版本,换句话说,如果你更新到5.0,不是你安不安Gutenberg这个插件的问题,而是你的默认编辑器直接就是Gutenberg。

    wordpress这样做的原因主要是想获得那些存粹只想模块化编辑的用户,这个以用户为导向的市场,wp作为一个开源程序还是妥协了,怎么说呢,欢迎更多新人加入到wordpress建站。

    同时,WP还重新换了架构,Gutenberg的框架是React,这是一个非常流行的JavaScript框架,由Facebook和Instagram等公司使用和维护。

    除此之外,Gutenberg还用了很多新技术,比如REST API,ESnext + JSX,WebPack,怪不得各大插件商要着急,因为他们也要按照更新去调整插件。

    说完了5.0的第一个变化Gutenberg,接下来说新主题Twenty Nineteen。

    Twenty Nineteen主题

    Twenty Nineteen是本次更新为Gutenberg专门定制的新主题,以后的wordpress默认安装都会是这个主题,而不再是Twenty Seventeen。总之这个主题不是拿来外贸建站的,我就不多说了。

    接下来谈谈5.0更新需要注意的问题。

    WordPress 5.0更新需要注意些什么?

    就一灯来看,大家不要急着更新,起码等1到2个星期的时间,等你使用的主题和插件都更新完,你再去更新wordpress 5.0,这样才不会出兼容性的错误问题,切记!

    一旦你开始更新,请遵循下面这个步骤。

    1. 先做网站备份,以防万一。
    2. 将所有插件和主题更新到最新版本。
    3. 安装Gutenberg插件,检查你的网站有没有什么错误。
    4. 卸载Gutenberg插件。
    5. 安装WordPress 5.0。
    6. 如果要使用旧的页面编辑器,请安装Classic Editor插件

    classic-editor插件

    总结

    wordpress作为世界上使用人数最多的CMS开源建站程序,全球每3个网站就有一个是wordpress做的。这么强大的自建站程序,每年都有几次更新升级,目的是为了让wordpress变的更安全,更好用。

    以前的更新都是补漏洞补bug,唯独12月6日发布的5.0是推新功能,所以大家还是要重视一下,特别是已经有SEO排名的网站,别一个更新直接废了你的排名。

    wordpress 5.0更新了什么,需要注意什么,我都已经在文里做了说明,请大家按照我说的去做就行了。最后希望wordpress从5.0开始变得越来越牛,简单到白痴都能建站。

    评论  3  访客  2  作者  1
      • Leo

        4.8的时候找了个新网站安装了谷腾堡是了下…结果全乱了. 又重新安装的wordpress….

          • 一灯

            @ Leo 已经5.1了,我还是没升级。。。

          • 明天不用早自习

            我的网站就自动更新了这个。,。那天上文章差点没吐血 吓得我又重新用回原来的wordpress 版本

          发表评论

          匿名网友